Выбрать - 1С: Предприятие Версия 7 Описание встроенного языка Часть 1

Выбрать


Выбрать элемент справочника в диалоге.

Синтаксис:


Выбрать(, )

Параметры:



Текст заголовка окна диалога выбора. Может ис­пользоваться в качестве подсказки конечному поль­зователю.
Строковое выражение идентификатора той формы списка справочника (как он объявлен в конфигура­торе), которая должна использоваться для выбора. Если это значение пустое, то используется форма списка по умолчанию.

^ Возвращаемое значение:


Числовое значение: 1 — если элемент выбран; 0 — если не выбран.

Описание:


Метод Выбрать вызывает диалоговое окно для выбора элемента и затем по­зиционирует справочник на выбранном элементе. Данный метод может исполь­зоваться только для объектов, созданных функцией СоздатьОбъект.

Пример:


// данная процедура присваивает некоторому реквизиту "Фирма"
// значение из Справочника.Фирмы
Процедура УстФирмы()
// Создадим объект требуемого справочника
Фрм = СоздатьОбъект("Справочник.Фирмы");
// реквизиты справочника могут быть периодическими
// поэтому установим дату выборки периодических реквизитов
Фрм.ИспользоватьДату(ДатаДок);
// Вызываем диалог выбора элемента Справочника
Если Фрм.Выбрать("Выберите фирму", "") > 0 Тогда
Фирма = Фрм.ТекущийЭлемент();
КонецЕсли;
КонецПроцедуры

^ См. также:

ВидыДляВыбора

ВидыДляВыбора


Установка выбираемых видов для справочника неопределенного вида.

Синтаксис:


ВидыДляВыбора()

Параметры:



Необязательный параметр. Строковое выражение, содержащее список видов выбираемых справоч­ников, разделенных запятыми.

^ Возвращаемое значение:


Строковое значение, содержащее текущий список видов выбираемых спра­вочников, разделенных запятыми (на момент до исполнения метода).

Описание:


Метод ВидыДляВыбора устанавливает выбираемые виды для объекта-справочника неопределенного вида. Данный метод обычно используется до начала интерактивного позиционирования элемента справочника, например, при помощи метода Выбрать.
Данный метод может использоваться только для объектов-справочников не­определенного вида, либо созданных функцией СоздатьОбъкт, либо опреде­ленных в конфигураторе как реквизиты диалога или другого объекта. Если метод ВидыДляВыбора применен к реквизиту диалога типа «справочник неоп­ределенного вида», то интерактивный выбор элемента справочника будет про­изводиться только среди установленных видов справочников.

Пример:


// данная процедура присваивает некоторому реквизиту "Фирма"
// значение из Справочника.Фирмы
Процедура УстФирмы()
// Создадим объект требуемого справочника
Фрм = СоздатьОбъект("Справочник");
// реквизиты справочника могут быть периодическими
// поэтому установим дату выборки периодических реквизитов
Фрм.ВидыДляВыбора("Фирмы");
Фрм.ИспользоватьДату(ДатаДок);
// Вызываем диалог выбора элемента справочника
Если Фрм.Выбрать("Выберите фирму", "") > 0 Тогда
Фирма = Фрм.ТекущийЭлемент();
КонецЕсли;
КонецПроцедуры

^ См. также:

Выбрать

ВыборГруппы


Установить режим выборки групп.

Синтаксис:


ВыборГруппы()

Параметры:



Необязательный параметр. Числовое выражение:
1 — выбирать группы; 0—не выбирать группы.

^ Возвращаемое значение:


Текущее числовое значение режима выборки групп (на момент до исполне­ния метода).

Описание:


Метод ВыборГруппы устанавливает режим выборки групп. Данный метод может применяться как для позиционируемых объектов, созданных функцией СоздатьОбъект, так и для элементов диалога для полей типа «справочник» (см. «Методы элементов диалога»).
По умолчанию, выборка элементов справочников для полей в формах доку­ментов, журналов и справочников установлена без выбора групп, а в форме отчета с выбором групп. Поэтому реально имеет смысл применять данный ме­тод только в том случае, если надо изменить режим выборки групп.

Пример:


* Если в форме документа необходимо, чтобы какой-либо реквизит "Статус" типа «справочник» мог принимать значения как элемента, так и группы, то этому реквизиту следует установить:
Статус.ВыборГруппы(1);
*
Спр = СоздатьОбъект("Справочник.Сотрудники");
// Задаем выборку без групп
Спр.ВыборГруппы(0);
// Открываем выборку
Спр.ВыбратьЭлементы();
// Цикл получения элементов справочника
Пока (Спр.ПолучитьЭлемент() > 0) Цикл
Состояние(Спр.Наименование);
КонецЦикла;
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат
Реферат